Promotion Email services experiencing delay due to recent AWS us-east impaired services.
Incident Report for Reflektion, Inc
Resolved
Promotional email is operational now.
Posted Nov 25, 2020 - 15:12 PST
Update
AWS has identified mitigation for this issue, and are actively working towards a resolution. The feed process will continue to take more time to finish. Next update in 2 hours. If the issue gets resolved sooner from AWS, will update you sooner.
Posted Nov 25, 2020 - 14:21 PST
Update
We are closely monitoring the various service outages reported by AWS. They have identified the root cause and making a progress in addressing it.
Posted Nov 25, 2020 - 12:58 PST
Monitoring
We are monitoring AWS resolving the issue.
Posted Nov 25, 2020 - 10:14 PST
Investigating
AWS is currently working on this issue. Feed sync processes are running but taking a little longer time. We see promotional email services sometimes taking longer to load.
Posted Nov 25, 2020 - 09:54 PST
This incident affected: Production Email Services.